Spark Editor

From NS2 community wiki
Jump to: navigation, search

The Spark Editor (pre-alpha) was released on November 23 2009 only to those who pre-ordered any version of NS2. The editor continues to evolve as work on NS2 continues. Please fix any errors or inconsistencies you see in this documentation.

This documentation is intended for reference purposes. To get mapping quickly take a look at the tutorial videos in Natural Selection 2 Mapping

Objects are made of faces, lines and vertices. Faces are only visible from one side. The visible side will be created with a dark or light gray texture with a grid pattern.



Layout

Whole-136-small.jpg

The main screen is split into 4 windows, a rendered perspective view (top left) as well as top, front and side views. These views can be changed by left clicking on the text labeling the view. For example, left click on the word "Perspective" to change from Textured Unlit(default) to Textured Lit. Lit renders require lights for anything to be visible.

Some tools pop up additional windows for picklists or properties. Thie default to the right side but can be dragged to the other edges or out to their own windows.

Axis

Axis.jpg

The Axis arrows point along each axis in the positive direction. X-Y-Z are red, green, and blue.


Basic Controls

Panning

In the perspective window, right click and drag will turn your point of view. This technique has no effect in the other three views.


Moving

Move the mouse over the view you want to affect. Hold the right mouse button. While right clicking, the A, S, F and D keys will move your view. In the Perspective view, these move your point of view left, backwards, right and forward. Forward and back are effectively zooming in and out.

In the Top, Front and Side views, the controls are slightly different. The ASFD move the view left, down, right and up.


Zooming

Move the mouse over the window you want to affect and use the scroll wheel.


Selecting a view

Views can be selected either by hovering the mouse over then without clicking or by clicking in the view. Hovering is useful for keyboard shortcuts. Clicking is useful for icon users.


Tools

Toolbar-136.jpg

Tool icons are across the top. The Tools menu has the keyboard shortcuts. Left clicking performs the action for the selected tool.


Select Tool

Toolselect.jpg

Use the left mouse button with the select tool to highlight the piece that you want to work on next. Click and drag with the select tool to window select everything at least partially within the window.

Use the filters at the bottom of the screen to include or exclude different items.

Hold the control key while clicking to add or remove additional items. This also works for click and drag window selects.


Line Tool

Toolline.jpg

Use the line tool to add lines. While drawing, lines snap to orthagonal directions, vertices and lines if they are nearby. It may be necessary to draw your line short and move the vertex exactly where you want it. Vertices can be moved after the line is drawn utilizing the move tool.

Lines can be drawn in empty space, connected to vetices, or across faces to split them in two. If a series of lines are drawn which form a closed polygon, a face is automatically created.


Rectangle Tool

Toolrectangle.jpg

Click and drag with the rectangle tool to create a new face. Faces can be created on other faces.


Circle Tool

Toolcircle.jpg

Click and drag to create an approximately circular face. The initial click will be the center and drag for radius.


Extrude tool

Toolextrude.jpg

The extrude tool moves one face and adds additional faces as needed. The direction of extrusion dictates whether the solid created is hollow with the visible faces pointing in, as a room, or solid with the visible faces pointing out, as in a crate. Additional uses of the extrude tool on the same face create new side faces.

For solid objects, extrude towards the visible side of the face.

For hollow objects, extrude in the opposite direction.

A solid hollow, as in a cup, can be made by using both extrudes.

Move Tool

Toolmove.jpg

The Move Tool is used for moving the selected item around. You can move vertices, lines, faces, lights, entities and props. To move something, select it with either the select tool or the move tool. Then hover over the colored axis arrows until the desired direction/axis is highlighted yellow. Click and drag in either direction on that axis.

Free movement is possible in two axises by hovering over the halfway point intersection of the colored axis. When you have the right spot, a yellow box will highlight the two axises you will be affecting. Click and drag the object to your desired location.

When moving portions of the geometry, textures will stretch to fit unless the "Lock Textures" button is de-selected at the bottom of the screen.


Rotate Tool

Toolrotate.jpg

See also Rotation snap, bottom left


Scale Tool

Toolscale.jpg

Use to scale things??


Paint Tool

Tooltexture.jpg

The Paint Tool is used to apply textures to faces. Faces can be selected by left clicking with the paint tool. Once an item and the paint tool is selected, the texture mapping and texture browser windows will open on the right. If these are closed, they can re-opend from the Window menu.

Textures are selected from the Texture Browser window. The built in search functionality is recommended. Texture Groups

Once applied, textures can be adjusted either in the views or via the Texture Mapping window. Scale and Shift have seperate axis controls. These are not labeled because they are relative to the face being editted.

Scale adjusts the ratio of the texture with 1 being the same as original sizing, 2 being twice as many tiles and 0.5 being half as many tiles. Bigger numbers are like zooming out.

Shift moves the texture around on the face. This might be especially useful if different parts of one texture wil be used for different faces on an object.

Create Light Tool

Toollight.jpg

The Create Light is used to add light sources to your map. These lights are omnidirectional. Use the select tool to select a light. This will bring up the Edit Window for the light allowing you to change the position, angle, color, max distance and intensity. Cast Shadows controls whether the selected light will throw shadows if the light strikes the visible side of a face.

Max Distance can be modified using the mouse by dragging the blue circle which is centered on the selected light.

Lights do not include an in-game model. You'll need to create an apparent light source out of faces or use a prebuilt entity.

Light and Shadows


Create Spotlight Tool

Toolspotlight.jpg
A spotlight viewed from behind. The Max Distance adjustment is highlighted.

The Create Spotlight is used to add directional light sources to your map.

After placing a light, use the select tool to select it. This will bring up the Edit Window for the light allowing you to change the position(origin), angle, color, max distance and intensity. Shadow casting is optional here too. Spot lights also have inner and outer angles, as well as an atmospheric toggle

Origin can be changed with the Move Tool. Angles with the Rotate Tool.


Max Distance, inner and outer angles can be adjusted with the mouse. Use the Select Tool to select a spotlight. In the perspective view, pan around until you are looking at the spotlight from behind at an angle. Hover over the dark blue lines and circles. Different points will highlight different portions in white. Max Distance is the biggest, most complicated looking highlight. After that, the biggest circle is Outer Angle and the smaller circle is Inner Angle.

Lights do not include an in-game model. You'll need to create an apparent light source out of faces or use a prebuilt entity.


Create Prop Tool

Toolprop.jpg

Use the Create Prop tool to add pre-made prop elements to your map. The Prop Browser window will open when the Create Prop is selected. Some props in the browser are not yet defined and will appear in the browser as empty gray squares. Select the prop to add then click in a view where you would like the prop to appear.

Props cast appropriate shadows.


Create Entity Tool

Toolentity.jpg

Use to place Entity objects. These are ingame objects such as marine/alien spawn locations and hives. To place an entity, select the Entity tool, click on the entity you want to place, click in a view where you want the entity to be placed. Some entities do not seem to allow placing.

After placing an entity, it's likely that you'll want to switch to the select or move tools to edit or adjust the new entity. Additional clicks with the entity tool will add more of the selected entity.

Placing a player_start entity is a useful way to check your sizes.

Entity Descriptions


Create Color Grading Tool

Toolgradient.jpg

Use to Color Grading Tool to add a color tinge to an area. When the player's point of view enters the Max Distance of the color grading, his view will be effected by the coloring.

Select the Color Grading Tool then click in a view to place it. The grading is represented by a cyan wireframe cube. When Selected the edit window is opening giving access to origin, angles, color balance, max distance, brightness and contrast. Placement(origin) and max distance can be modified using the mouse.


Refine Grid

Toolrefine.jpg

Click this button to move the snap grid to the next finer setting. Example: 2" down to 1".


Coarsen Grid

Toolcoarsen.jpg

Click this button to move the snap grid to the next coarser setting. Example: 2" up to 4".


Zoom to Selected Elements

Zoomelement.jpg

Hover your mouse pointer over the view you want to change and press Z. That view alone will zoom to and center on the currently selected item. If no items are selected, the view will not change.


Maximize Viewport Toggle

Toolmaxview.jpg

Use this tool to toggle between the split 4 pane view or a large single view. Click on the view you want to focus on then click the Maximize Viewport Toggle button.


Filters

Filters.jpg

Along the bottom of the editor are several locks which limit the effect of some tools. Filters are available to allow access to vertices, lines, faces, lights, props, and entities. By default all filters are on, allowing access to all items. Filters affect the select, move, rotate and paint tools. If you are unable to use a tool on an item, check that the filters are not set to exclude it.


Edit Menu

The Edit Menu changes depending on the currently selected tool and item.

Cut, copy, paste, delete, undo, redo, select all, clear selection should behave as expected.


Duplicate Selection

Flip Selection (X Axis)

Flip Selection (Y Axis)

Flip Selection (Z Axis)

Flip Face

Use this tool to change which side of a face is visible. Select a face, then use the Flip Face function. Note, this is requires the face be selected, this does not include lines or vertices.


Create Face

While some faces will be created automatically when polygons are closed, the Create Face tool is used to to add additional faces. Select all vertices and lines that surround the new face. Then use the Create Face Tool. You may need to use the Flip Face tool to make the face visible on the correct side.


Weld Vertices

Combines two selected vertices into a single vertex. Vertices must be closer than 1" to be merged. The easiest way to see if two vertices are welded is to try moving the vertex. Note whether all connected lines move too. Then Undo the change. Make sure that you are using the selection tool when attempting to weld vertices.

Locks

Texture lock

Texturelock.jpg

When enabled, the move tool causes textures to stretch. When disabled, textures are tiled to fill the new space. The texture lock button is only visible when the move tool is selected.


Movement Snap

Gridlock.jpg

Use this to enable snap-to-grid. The check box enables or disables this function. The drop-down menu configures the grid size. Grid sizes are measured in inches.


Rotation Snap

Rotatelock.jpg

Use this to constrain the angles available to the rotate tool. The check box enables or disables this feature. The drop-down lets you control the angle setting in 2, 5, 22.5, 45 and 90 degrees.


Layers

Layers.jpg

Access the layers window via the Windows menu. Layers allow you to seperate different parts of your map and hide some to make edits easier. Vertices, Props, Lights and Other Entities can be assigned to layers.

To add or remove items to a layer, select the item and click the checkbox on the layers window. Items can be on more than one layer at the same time.

Hide or show all items in a layer by clicking on the eye-shaped icon.

Rename layers by double clicking the current name. The default name is simply "Layer." This rename menu also allows you to assign a color to each layer. Colors make it easier to differentiate layers in the layer window. Colors do not affect the views.

Known Issues

Personal tools